nend

  • When is a theme, no longer what it was when installed?
  • Posts: 165
Captcha doesn't work in Chrome
« on March 21st, 2012, 04:19 AM »
Since I had a difficult time registering and had to open Firefox to register, I am going to pester you with a bug report. I thought it was a clever scheme of showing a blank box, which meant don't type anything in.

I don't know about other webkit browsers, but the captcha does not work in Chrome because of the lack of APNG support. The main reason I believe though is because of the Portable Network Graphics group never accepted the proposed animated PNG and truthfully their isn't really one standard for it. Mozilla however has a definition of the standard which is widely accepted, but it isn't a real standard and isn't set in stone.

So basically what I am getting at, is APNG's don't work on all browsers. ;)

live627

  • Should five per cent appear too small / Be thankful I don't take it all / 'Cause I'm the taxman, yeah I'm the taxman
  • Posts: 1,664
Re: Captcha doesn't work in Chrome
« Reply #1, on March 21st, 2012, 07:06 AM »
Some are animated, some are not. Would it work if animated images are disabled in Chrome?
A confident man keeps quiet.whereas a frightened man keeps talking, hiding his fear.

Nao

  • Dadman with a boy
  • Posts: 15,465

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Captcha doesn't work in Chrome
« Reply #3, on March 21st, 2012, 10:48 AM »
Correct. The code does not at any point generate APNGs so if it did generate an APNG something is very fundamentally wrong...
Posted: March 21st, 2012, 10:42 AM

And I'd be even more surprised if it didn't work in Chrome seeing as that's where I wrote and tested it...
When we unite against a common enemy that attacks our ethos, it nurtures group solidarity. Trolls are sensational, yes, but we keep everyone honest. | Game Memorial

nend

  • When is a theme, no longer what it was when installed?
  • Posts: 165
Re: Captcha doesn't work in Chrome
« Reply #4, on March 21st, 2012, 04:13 PM »
I disabled all plugins in Chrome and the issue disappeared. One of my plugins seemed to be causing the problem. Just weird though because yesterday I was sure it said APNG for the image.

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Captcha doesn't work in Chrome
« Reply #5, on March 21st, 2012, 04:15 PM »
Hmm, that's a bit weird. But, no they're definitely GIFs, especially the animated ones (there's a class whose sole job it is to combine the images effectively and preserve transparency between frames properly)

nend

  • When is a theme, no longer what it was when installed?
  • Posts: 165
Re: Captcha doesn't work in Chrome
« Reply #6, on March 21st, 2012, 04:50 PM »
Found the problem, there is a plugin for Chrome that I installed a while back that is conflicting with your GIF. Strange though because it doesn't miss with any other GIF on the site. I installed this plugin to give Chrome APNG support but it looks to cause other problems. The plugin is... https://chrome.google.com/webstore/detail/ehkepjiconegkhpodgoaeamnpckdbblp.

I don't expect you to build compatibility if it is the plugins fault, because that would be the responsibility of the plugin developer. Just thought I would let you know I figured out what was causing the problems.

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Captcha doesn't work in Chrome
« Reply #7, on March 21st, 2012, 05:01 PM »
Hmm, maybe there's something in the animated GIFs that is haywire then. They are built with a rather interesting process, after all...

Thanks for the link, I'll look into it.
Re: Captcha doesn't work in Chrome
« Reply #8, on April 6th, 2012, 04:02 PM »
I've had a look and I can see where there's a problem: the library is essentially reparsing image files and redrawing them onto a Canvas, and this doesn't work for animated GIFs.

I'm not sure how best to work around this, to be honest, since they're animated GIFs that load correctly in everything I've tried them on so I'm going to have to say it's a problem for the plugin author, and I'll raise the issue there.
Re: Captcha doesn't work in Chrome
« Reply #9, on April 7th, 2012, 11:20 PM »
This should be corrected in the latest version of the plugin, according to the notice I got from the author :)