Test topic...

Nao

  • Dadman with a boy
  • Posts: 16,077
Test topic...
« on March 29th, 2012, 06:49 PM »Last edited on November 9th, 2013, 12:44 AM
(click to show/hide)
Hmm.

Even though it is definitely set to 'quoted=optional' in the database..]]>Test..
Test topic.
« Reply #1, on March 29th, 2012, 06:50 PM »Last edited on November 9th, 2013, 12:05 AM
Hey... It actually works?!

(click to show/hide)
Hmm.

Okay, it's when you don't add quotes that it fails... Which makes sense, somehow...

:edit:
Re: Test topic.
« Reply #2, on March 31st, 2012, 05:16 PM »
Quote from Nao on March 29th, 2012, 06:50 PM
Hey... It actually works?!

lmlkmlmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlmklkmlkmlkmlkm4545645645654645654564645546456456456546456lkm

Okay, it's when you don't add quotes that it fails... Which makes sense, somehow.
Test.

lmlkmlmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlkmlmklkmlkmlkmlkm4545645645654645654564645546456456456546456lkm

Posted: March 31st, 2012, 05:15 PM

Seems to work for me...?
Re: Test topic.
« Reply #4, on April 6th, 2012, 10:10 AM »
Okay, here's the deal... I can't get the url problem to reproduce here. Is this a special board that is entirely bug-free? :P

Try to edit my post, Pete!

Test. Test.
http://wedge.org
Re: Test topic.
« Reply #5, on April 6th, 2012, 10:11 AM »
Hey... Interesting. Now I can reproduce.

Test. Test.
http://wedge.org

The problem doesn't happen when I quick edit an existing post to add a straight URL. If I save, then quick edit again, the link is url-tag free.

Editing this post again... It never happens! Surprising. So there's something happening generally, that doesn't happen when quick editing to add the link.

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Test topic.
« Reply #6, on April 6th, 2012, 01:06 PM »
Quick editing goes through a different code path to main posting, as I commented when this first occurred.

Need to compare the path of Post2.php to JSModify.php and see where the difference is, I'll look at that shortly.
When we unite against a common enemy that attacks our ethos, it nurtures group solidarity. Trolls are sensational, yes, but we keep everyone honest. | Game Memorial

agent47

  • Now I see the changes you're talking about.
  • Posts: 115
Re: Test topic.
« Reply #7, on April 10th, 2012, 06:56 AM »
Something that you should really know about me is that...........
(click to show/hide)
me like big boobies :p

Nao

  • Dadman with a boy
  • Posts: 16,077
Re: Test topic.
« Reply #8, on April 10th, 2012, 10:45 AM »
(click to show/hide)

Bug!

The multi-word spoiler tag actually works on first post, but breaks on quick edit...!
Re: Test topic.
« Reply #9, on April 10th, 2012, 10:46 AM »
(click to show/hide)
As evidenced here...

BTW, full posting doesn't add the closer spoiler tag, while quick edit does.
Re: Test topic.
« Reply #10, on April 10th, 2012, 11:11 AM »
Kay then...
First post is using entities (quot) in the database. Second post isn't.
That's the reason for the bug... YET another issue with preparsing, this time the other way around (i.e. quick edit adds the bug.)

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Test topic.
« Reply #11, on April 10th, 2012, 12:00 PM »
Yay for entirely separate code paths -_-

Nao

  • Dadman with a boy
  • Posts: 16,077
Re: Test topic.
« Reply #12, on April 10th, 2012, 12:01 PM »
I, for one, would love to know why this is happening at all.
And another reason for me to advocate using double quotes in the DB, rather than quot entities... :whistle:

Arantor

  • As powerful as possible, as complex as necessary.
  • Posts: 14,278
Re: Test topic.
« Reply #13, on April 10th, 2012, 12:08 PM »
Because quick edit does something totally separate to Post2.php, it never actually calls either Post file at all, it's all in JSModify.php - and preparsecode is called at a different time, and notably, the Aeva on-posting code is never called at all (which is why the other stuff re the url bbcode doesn't happen in quick editing)


Even more than ', it bothers me about having " tags, and I'm not sure you wouldn't have to alter how the bbc parser works then since some parameters can be quoted.

Nao

  • Dadman with a boy
  • Posts: 16,077
Re: Test topic.
« Reply #14, on April 10th, 2012, 12:34 PM »
IIRC, Aeva's onposting wasn't called because of incompatibilities with the JS handling or something... But that's probably something that could be fixed.

Also, the question is to know whether or not this is a Wedge or SMF bug... (the quote stuff.)

SELECT * FROM wedge_messages WHERE body LIKE '%"%'

Showing rows 0 - 29 ( 3,987 total, Query took 0.0035 sec)

Yeah... Funny eh? Apparently double quotes have been happily living in our database forever without any worries...