This topic was marked solved by its starter, on March 17th, 2015, 02:56 PM

Kian

  • Posts: 38
Topic merging not working anymore
« on January 26th, 2015, 11:24 AM »
Hi,

The topic merging function seems to be KO. Whenever I try to merge to topics, I get :
Code: [Select]
The database value you're trying to insert does not exist: deleted_topics

When I want to merge 2 topics, in the menu, I cannot set "Section de destination:". It just stays on the same.
And if I manually enter the target topic's ID it alwatys says the same error.

I just tried again with 2 new topics, same result.

Code: [Select]
Type d'erreur Critiques
URL  http://www.potesnroll.com/do/mergetopics/?sa=execute
The database value you're trying to insert does not exist: deleted_topics
Function: MergeExecute
Fichier: /opt/sites/www.potesnroll.com/www/gz/app/Merge.php
Ligne: 551

I tried to update the forum software to sort out the issue but it didn't to anything.
I have the git build from January 22nd.

Nao

  • Dadman with a boy
  • Posts: 15,997
Re: Topic merging not working anymore
« Reply #2, on January 26th, 2015, 01:19 PM »
On dirait que la ligne 563 devrait être plus haut dans le code... Je ferai sous peu un blame pour déterminer pourquoi ça se trouve là.
Re: Topic merging not working anymore
« Reply #3, on January 27th, 2015, 12:12 AM »
From what I can see, the whole topic merging feature was broken in late 2010, and no one ever noticed that.. Maybe because it was only broken if Pretty URLs were enabled...

Kian

  • Posts: 38

developer

  • Posts: 5

Nao

  • Dadman with a boy
  • Posts: 15,997

Kian

  • Posts: 38

Nao

  • Dadman with a boy
  • Posts: 15,997
Re: Topic merging not working anymore
« Reply #9, on February 20th, 2015, 12:11 PM »
Are you still getting the same errors..?
Still giving you the same error? Even after updating the proper files..? Did you test on new dummy topics?

Kian

  • Posts: 38
Re: Topic merging not working anymore
« Reply #10, on March 17th, 2015, 02:56 PM »
Quote from Nao on February 20th, 2015, 12:11 PM
Are you still getting the same errors..?
Still giving you the same error? Even after updating the proper files..? Did you test on new dummy topics?
A the time it did not work, even with new dummy topics.
I just updated Wedge and now topic merging works perfectly  :cool:

Nao

  • Dadman with a boy
  • Posts: 15,997