Gargoyle

  • Posts: 12
Re: On Mobile Theme...
« Reply #45, on November 10th, 2013, 06:12 PM »
I disagree it wasn't there when I checked it earlier... Was totally fixed.  I am using ios7 with mobile safari.  I will go check again right now as it WAS working.
Re: On Mobile Theme...
« Reply #46, on November 10th, 2013, 06:14 PM »
Im thinking pentaxin is just looking at the pic I posted instead of the thread itself.  Still looks fine to me.. Im going to see what I need to do to swap themes.

Nao

  • Dadman with a boy
  • Posts: 16,062
Re: On Mobile Theme...
« Reply #47, on November 10th, 2013, 06:17 PM »
Yeah that could be the reason lol. I actually got fooled when using browserstacks (iOS 6 only) to generate a screenshot of this page. I only saw your shot. And thought it was broken.

Please test in both wireless and wilderless. It's important. Then I may do one final test later and we'll call it quits. ;)

Gargoyle

  • Posts: 12
Re: On Mobile Theme...
« Reply #48, on November 10th, 2013, 06:18 PM »
Looks great on both themes....  The only thing I notice is the link tree gets a little smashed up at the end.. (runs out of space) but the iphone uses a smallish screen and I think most people know that and can deal with it.  Otherwise it looks great. Display is very nice and no overlapping on either theme. Wireless or Wild---whatever how you spell it...

Once again iOS7 and mobile safari. Using an iPhone 4s.
Re: On Mobile Theme...
« Reply #49, on November 10th, 2013, 06:32 PM »
Ok using an old iPad I have laying around.  iOS 5.1.1 and mobile safari the issue is still there.  Honestly being as ios 5.1.1 isn't supported by apple anymore I don't think I'd worry about it to much honestly.  I think I have an iPod running iOS 6. I'll go check with that a sec.

Nao

  • Dadman with a boy
  • Posts: 16,062
Re: On Mobile Theme...
« Reply #50, on November 10th, 2013, 06:45 PM »
Hey, my iPod is still running 5.1.1... :P Never bothered to upgrade, since I stopped using it a year ago (was getting too slow, really.)

I've found my cable, I'll just restart it, for old time's sake, and see if I can reproduce there, eh...

Gargoyle

  • Posts: 12
Re: On Mobile Theme...
« Reply #51, on November 10th, 2013, 06:48 PM »
Holy cow... Wedge doesn't wanna load for me today.. Took forever.. Anyway..

iOS 5 and Ipad... Works great until logged in.. Once logged in the user name and reply number text overlap.
iOS 6 and iPod... Same as above
iOS 7 and iPhone.. Same as above

Seems to work perfectly until you are logged in. Then the overlap happens. Hope this helps some. I wasn't logged in before so my apologies. Once I saw the issue I re-checked with all the iOS stuff I have laying around.

Nao

  • Dadman with a boy
  • Posts: 16,062
Re: On Mobile Theme...
« Reply #52, on November 10th, 2013, 06:54 PM »
iOS 5.1 + iPod Touch: works great in Wilderless, then as you imply, it fails once I log in. >_< Dunno why.

Yeah, still, that's a good direction to look into! At least I know that I can analyze both my ios CSS cached files, and see what the differences are.
Posted: November 10th, 2013, 06:51 PM

Does this happen on your posts only? (i.e. posts where you probably have a checkbox next to the post title...)
Re: On Mobile Theme...
« Reply #53, on November 10th, 2013, 07:33 PM »
Well, got my answer... There was a JavaScript error, which occurred on all mobile themes, if the user wasn't logged in, and thus had no rights. (It wouldn't happen on boards where guests are allowed to post, but it doesn't matter.)

And as I expected, fixing this bug suddenly makes the CSS fail in guest mode as well. Meaning, well... That it's all due to a JavaScript problem in the first place, and CSS hacks won't help at all, eh.

Was looking in the wrong place... Now I need to determine what JS function changes anything in that area. My bet is on mini-menus, of course.

:edit: Confirmed. Disabling mini-menu code will make it work. Uh. So, it's back to being a CSS problem, I guess... :^^;: (As: CSS added by the JS function.)
Re: On Mobile Theme...
« Reply #54, on November 10th, 2013, 07:41 PM »
Setting .mime to position: static, as I tried yesterday, makes it work on my iPod, but of course it screws up the menu. :-/
Seems to be the thing I dreaded. I'm not sure why it failed yesterday, though..??

Pentaxian

  • Ah!
  • Posts: 20
Re: On Mobile Theme...
« Reply #55, on November 11th, 2013, 06:13 PM »
Wireless and Wilderless both still overlap on iPad Air and iPad3 with ios7.

Nao

  • Dadman with a boy
  • Posts: 16,062
Re: On Mobile Theme...
« Reply #56, on November 11th, 2013, 08:56 PM »
Yup... As I said, since I was able to reproduce on my iPod Touch with iOS 5.1, from now on I won't have to rely on others to tell me about whether it's okay or not.

Unfortunately, as I pointed out yesterday, I'm in a (sad) position where I have to consider disabling user menus entirely for iOS users.
Re: On Mobile Theme...
« Reply #57, on November 14th, 2013, 12:20 PM »
Ahem.

Fixed.

Partially my fault.

Let's forget about it. I wasted enough time on that 'bug'.