Gargoyle

  • Posts: 12
Re: On Mobile Theme...
« Reply #30, on November 6th, 2013, 02:43 AM »
Overlap in a few spots.  Screen shot attached.

 image.jpg - 116.97 kB, 640x960, viewed 240 times.


Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #31, on November 6th, 2013, 08:18 AM »
Known issue. Already discussed on other topics. Please note that this is iOS only and as such, I can't test it myself and fix it. Someone else will have to figure it out. :-/
Re: Safari 7 on Mac OS X 10.9
« Reply #32, on November 7th, 2013, 01:40 PM »
I've made a quick change to the template; can you re-test in Safari Mobile, and tell me if the problem is still there..?

PS: merged with the private topic. It didn't have any 'privatey' bits, so I didn't see why not.

Pentaxian

  • Ah!
  • Posts: 20

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #34, on November 8th, 2013, 05:11 PM »
Well, at least I can get rid of that ugly fix I made yesterday... :^^;:

I'm afraid it's due to the position: relative I have in the user name, then... Which means, it's pretty much impossible to fix it without rewriting the mini-menu layout system, and I'm, err... Not a fan of the idea. While getting the menu out of that particular DOM node (sorry for talking rubbish :P) would help with some earlier z-index issues (I already apologized!), it also means that any changes to the page dimensions would need to be passed on to the mini-menu manually, and... Well, it sucks.
Re: On Mobile Theme...
« Reply #35, on November 9th, 2013, 12:56 AM »
What about now?
(In Wireless; not in Wilderless.)

Pentaxian

  • Ah!
  • Posts: 20

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #37, on November 9th, 2013, 11:35 AM »
Oh, bugger...
Posted: November 9th, 2013, 11:33 AM

How 'bout now?
I insist, these tests must be done on Wireless, not Wilderless. Wilderless is the current 'default' mobile skin, so you have to consciously switch to it. If you didn't do it, then the previous test was for nothing.

If the current test works for you, then it means the profile mini-menus have to go from Wireless, at least in that position.

Pentaxian

  • Ah!
  • Posts: 20

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #39, on November 9th, 2013, 06:33 PM »
Hoping for this one to be the last... :^^;:

Changed Wireless to use floats instead. Seriously-- this one should work.
Changed Wilderless to use inline-blocks. I also tweaked the CSS to correctly align the elements vertically along the same line.

Please test both! Anyone who's got access to iOS, really.

Gargoyle

  • Posts: 12
Re: On Mobile Theme...
« Reply #40, on November 9th, 2013, 10:11 PM »
Looks great to me. Just loaded it and all looks good!!!

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #41, on November 9th, 2013, 10:39 PM »
On both skins? Which platform already?
Re: On Mobile Theme...
« Reply #42, on November 9th, 2013, 11:21 PM »
Oops. I made a wrong manipulation on my Wireless file, and reverted it to the 'original'. I'm hoping the Wilderless works for both of you, and it's not just Wireless that worked, although I don't think it'd be too hard reproducing the float layout I'd made for it... :^^;:
Really, though, Wilderless is the way I'd like to fix it, including in Wireless, so hopefully it'll be the right one, eh..?

Hmm, one thing I'd like to try, though, is reverting Wilderless back to use display: inline instead of display: inline-block, so that I don't have to add a hack for it on older browsers, but then again... It's only for IE6 and IE7. I'm sure they've got a ridiculous user base, by now...

Pentaxian

  • Ah!
  • Posts: 20
Re: On Mobile Theme...
« Reply #43, on November 10th, 2013, 12:04 AM »
Both in Wireles as in Wilderless, still there. I feel for you!

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: On Mobile Theme...
« Reply #44, on November 10th, 2013, 01:29 PM »
Restored the float hack in Wireless; please test again. :^^;:
(Unfortunately it's not pixel-perfect, unlike the Wilderless hack...)

Can you remind me your version of iOS, already..?

Maybe it's a simulator-only bug, although I doubt it.
Posted: November 10th, 2013, 12:49 AM

Still waiting for feedback on this. :whistle: