This topic was marked solved by Nao, on May 29th, 2014, 08:33 PM
« [switch languages] Weird error
follow_me() bug, shows up from time to time.

Nao

  • Dadman with a boy
  • Posts: 16,063

Leftie

  • Atomic Wedgie
  • I don't know what I'm doing, just roll with it.
  • Posts: 24
Re: follow_me() bug, shows up from time to time.
« Reply #16, on May 23rd, 2014, 09:22 AM »
(click to show/hide)
Quote from Nao on January 29th, 2014, 03:58 PM
Okay, I can (finally!) reproduce this all the time... Under Opera 20 Developer, with web platform disabled.
Take a topic that only has me in it (hello!), such as Plugin Revs or New Revs.
From the homepage, open it in a new tab by middle-clicking it.
*Wait for it to load*. This is important!
Then switch to it. Problem reproduced.
If you switch to the new tab as soon as you launch it, then the script will apply proper dimensions to the user box. If you don't, then it will screw up.
Which is really, really odd because topic.js has pagevisibility events that are specifically there to avoid this problem... :-/

Can anyone confirm, maybe..? With Chrome, or Firefox, or anything?

I too have noticed this bug from time to time, but never saw the steps to reproduce it consistently. Thus all I can confirm right now is that the above steps do not cause it to manifest. At least not anymore. At least not on Firefox 29.0.1. At least not on my computer.

I'm sure that was incredibly helpful ::)
Never underestimate the power of stupid people in large groups

Nao

  • Dadman with a boy
  • Posts: 16,063
Re: follow_me() bug, shows up from time to time.
« Reply #17, on May 23rd, 2014, 11:35 PM »
I THINK I've fixed it (again), with the removal of my min-height restraints.

It still doesn't guarantee that a wrong width will be calculated, which might influence paddingTop when scrolling down and thus re-create the infamous infinite height divs, BUT at least there's one less thing to calculate, and this makes it all faster.

Please keep me posted, guys...

Sara

  • Walking Contradiction
  • Posts: 41

Nao

  • Dadman with a boy
  • Posts: 16,063

« [switch languages] Weird error