Wedge

Public area => The Pub => Support => Topic started by: Zeyad_Ahmed on June 12th, 2016, 04:23 PM

Title: I want a wedge support 5.2 PHP IS it Possible
Post by: Zeyad_Ahmed on June 12th, 2016, 04:23 PM
I want a wedge support 5.2 PHP IS it Possible
Title: Re: I want a wedge support 5.2 PHP IS it Possible
Post by: emanuele on June 12th, 2016, 10:15 PM
I feel it would be kinda tough: Wedge makes extensive use of closures that are supported on in php 5.3+.
Additionally, even php 5.3 is already several years old, there is little excuses not to use at least 5.3.
Title: Re: I want a wedge support 5.2 PHP IS it Possible
Post by: Nao on September 21st, 2016, 11:01 AM
Some days, I even wonder if I shouldn't make PHP 7 a requirement, lol...
But that's mostly because the Wedge userbase isn't really huge, so I could actually get away with it...

I just love using "$var ?? 1" instead of "isset($var) ? $var : 1"... Plus, the HHVM performance!
Title: Re: I want a wedge support 5.2 PHP IS it Possible
Post by: CerealGuy on September 22nd, 2016, 06:32 PM
Why do you want support for an old php version? XY Problem?

http://mywiki.wooledge.org/XyProblem

So, what do you REALLY want to do? :D
Title: Re: I want a wedge support 5.2 PHP IS it Possible
Post by: Nao on September 23rd, 2016, 11:15 AM
Nice link/theory!