Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Norodo
16
The Pub / Re: Wedge repo -- installation feedback
« on January 25th, 2014, 03:46 PM »
Quote from Nao on January 24th, 2014, 05:31 PM
I've added a few bytes to inserting dummy empty values, but honestly, I'm not thrilled with that... Does that mean you'll get the same errors when creating new boards and posting messages..?
Actually, I get

Code: [Select]
Database Error

File: /Users/Finn/Sites/wedge/gz/app/Subs-Post.php
Line: 1225

When posting messages. Creating boards is okay though.
Quote from Nao on January 24th, 2014, 05:31 PM
Any reasons why Wedge should fail to find any board category..?
On what page are you getting these errors, exactly?
Used to get them on index.php?action=moderate but after adding a board and doing some other things I no longer do.
17
The Pub / Re: Wedge repo -- installation feedback
« on January 25th, 2014, 02:37 AM »
Quote from Nao on January 24th, 2014, 05:31 PM
This makes absolutely no sense at all...
Especially since lines 626 and 1735 are both about adding data to the table, so it implies that the table was properly created.
I've added a few bytes to inserting dummy empty values, but honestly, I'm not thrilled with that... Does that mean you'll get the same errors when creating new boards and posting messages..?
I'll get back to you on that.
Quote
Yeah, well, doesn't make sense either... Or maybe you didn't chmod your /gz/ folder properly...? (It needs to be chmodded, like all of its children -- at least until I get to rewrite the install process, as mentioned above.)
I chmodded everything and everything else worked. I have no idea. Just the lockfile that I had to create. I'll see if I can replicate the error.
Quote
Any reasons why Wedge should fail to find any board category..?
On what page are you getting these errors, exactly?
This is on a log page for moderation (I think?) It has no entries, so that might be it.

Sorry, just got home from a party. I'll probably be more constructive tomorrow!
18
The Pub / Re: Wedge repo -- installation feedback
« on January 24th, 2014, 03:41 PM »
I've managed to install Wedge somewhere, finally. It's on my laptop localhost. I did get this error message while installing:

Code: [Select]
Some of the queries were not executed properly. This could be caused by an unsupported (development or old) version of your database software.

Technical information about the queries:
Line #626: Field 'offlimits_msg' doesn't have a default value
Line #1735: Field 'data' doesn't have a default value

But it seems to work. I run MySQL version: 5.6.15

Code: [Select]
In my error log I got:
 2: filemtime(): stat failed for /Users/Finn/Sites/wedge/gz/cache.lock

But all I had to do was touch cache.lock to create the file and now it doesn't give that error any more.

I also got this after opening logs:
Code: [Select]
8: Undefined offset: 0
File: /Users/Finn/Sites/wedge/gz/app/Subs-BoardIndex.php
Line: 472

All in all it seems to work!
19
Plugins / Re: Plugin request - Ad Management
« on January 24th, 2014, 01:20 AM »
Make a paid advert module man. It seems like a good idea for everyone. :)

(That is, everyone except for people like me who would rather you work on Wedge, because we don't advertise on our forums.)

But for you and the adverts gang, it's a win win!
20
The Pub / Re: Wedge repo -- installation feedback
« on January 22nd, 2014, 06:05 PM »
I'll get a testing setup done and give you the details over PM sometime after dinner today.
21
The Pub / Re: Wedge repo -- installation feedback
« on January 22nd, 2014, 05:25 PM »
I have now removed the root .htaccess and... Still getting 500s for the CSS.

I also get 'weUrl' is undefined in my error log.

Code: [Select]
Uncaught ReferenceError: weUrl is not defined index.php?action=skin;u=1:245
22
The Pub / Re: What I HATE in Wedge!
« on January 22nd, 2014, 02:26 AM »
The fact that I absolutely can't seem to get it working with my web host.
23
The Pub / Re: What I LIKE in Wedge!
« on January 22nd, 2014, 02:25 AM »
It's being developed by the coolest developer I know. I really like how it looks and feels when installed :)
24
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 08:39 PM »
Hm. Yes, my server allows .htaccess files. It's a fairly standard shared hosting AMP install, apart from the MariaDB.

This is the .htaccess file in the css folder:

Code: [Select]
<Files *.php>
Deny from all
</Files>

<Files index.php>
Allow from all
</Files>

<IfModule mod_mime.c>
AddEncoding x-gzip .gz
AddEncoding x-gzip .cgz
AddEncoding x-gzip .jgz
<FilesMatch "\.(js\.gz|jgz)$">
ForceType text/javascript
</FilesMatch>
<FilesMatch "\.(css\.gz|cgz)$">
ForceType text/css
</FilesMatch>
</IfModule>

<IfModule mod_headers.c>
Header set Cache-Control "max-age=2592000"
Header set Expires "Thu, 21 March 2025 03:42:00 GMT"
Header set Vary "Accept-Encoding"
</IfModule>

FileETag none

This is my root .htaccess (i keep software in subdirectories of this folder):

Code: [Select]
Options -MultiViews +FollowSymlinks -Indexes
<IfModule mod_security.c>
# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>

DirectoryIndex index.php portal.php index.xhtml

ExpiresActive On

ExpiresByType image/gif A2592000
ExpiresByType image/png A2592000
ExpiresByType image/jpg A2592000
ExpiresByType image/x-icon A2592000
ExpiresByType application/pdf A2592000
ExpiresByType application/x-javascript A2592000
ExpiresByType text/plain A2592000
ExpiresByType text/css A604800

<IfModule mod_env.c>
SetEnv SEO_SUPPORT 1
</IfModule>
</IfModule>

AddType application/x-7z-compressed 7z

<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/javascript text/css text/html text/xml
</IfModule>

25
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:59 PM »
As an aside, it also does this on install.

Code: [Select]
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://zeldaengine.net/beta/wedge-master/gz/js/script-m-326310.js
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://zeldaengine.net/beta/wedge-master/gz/css/install/chrome32-326310.css
Uncaught TypeError: Object [object Object] has no method 'sb'
26
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:49 PM »
I'm going to try a quick reinstall...

One thing that is annoying is that web owns all cached files so I have to take posession over them.
27
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:48 PM »
I'm using Apache 2.4.

With Google Closure:
Code: [Select]
GET http://zeldaengine.net/beta/wedge-master/gz/css/Wilde/chrome32-admin-326310.css.gz 500 (Internal Server Error) index.php:13
GET http://zeldaengine.net/beta/wedge-master/gz/js/script-m-326310.js.gz 500 (Internal Server Error) index.php:21

With JsMin:
Code: [Select]
GET http://zeldaengine.net/beta/wedge-master/gz/js/script-m-326310.js.gz 500 (Internal Server Error) index.php:21
GET http://zeldaengine.net/beta/wedge-master/gz/css/Wilde/chrome32-admin-326310.css.gz 500 (Internal Server Error) index.php:13

With no minify:
Code: [Select]
GET http://zeldaengine.net/beta/wedge-master/gz/css/Wilde/chrome32-admin-326310.css.gz 500 (Internal Server Error) index.php:13
GET http://zeldaengine.net/beta/wedge-master/gz/js/script-m-326310.js.gz 500 (Internal Server Error)
28
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:34 PM »
That does not seem to help, but it was a good idea. :)

Code: [Select]
'weUrl' is undefined

Interesting. I'm going to poke around a bit.
29
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:22 PM »
Well, starting from the top again, chmod -Ring 777 to /gz/ and all the other folders specified at installation start, I got a little bit closer. Now I get an unstyled Wedge install.

Code: [Select]
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://zeldaengine.net/beta/wedge-master/gz/css/Wilde/chrome32-guest-326310.css.gz
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://zeldaengine.net/beta/wedge-master/gz/js/script-sha1-326310.js.gz
Uncaught ReferenceError: weUrl is not defined index.php?topic=1.msg1:218
Failed to load resource: the server responded with a status of 500 (Internal Server Error) http://zeldaengine.net/beta/wedge-master/gz/js/topic-326310.js.gz
Uncaught TypeError: Object [object Object] has no method 'mime' index.php?topic=1.msg1:222

30
The Pub / Re: Wedge repo -- installation feedback
« on January 21st, 2014, 07:07 PM »
Quote from Nao on January 21st, 2014, 06:20 PM
You have to follow the instructions... :P
/gz/ and its sub-folders need to be writable (CHMOD 0755).
Huh? I did what the installation told me to do. /gz/ is indeed writeable, as is css keys and js. You might want to add a check for /app/ too if that's needed as well.

Either way, I changed /app/ to be writeable as well and now I get a 500 internal server error. Grand. :whistle:

I'll try to start from the top again...